Skip to content

No version that satisfies the requirement

Problem

I created a new deployment, or uploaded a new deployment package and my building failed. In the logs I can see the the following error:

Error: could not find a version that satisfies the requirement xyz==...

Solution

The most likely cause of this is that the version of the dependency you specified in your requirements.txt is not available for the Python version you have selected for your deployment. You need to alter the Python version of your deployment version to one where your specified dependency is available:

  1. First, check which Python version you were using for which your specified dependency was available.

  2. Then, navigate to your specific deployment version for which the build failed, and click "duplicate".

  3. Head to the "Deployment package" step in the duplication form and pick the correct Python version from the language dropdown. Leave the other settings as they are.

  4. Click "Create".

Your deployment will start building again and you should no longer receive the dependency error. If you do, please check your requirements.txt file for typo's.